Quellcode-Bibliothek
© Kompilation durch diese Firma
[Weder Korrektheit noch Funktionsfähigkeit der Software werden zugesichert.]
Datei:
BS.java
Sprache: JAVA
Untersuchungsergebnis.spec Download desScala {Scala[95] Lisp[134] CS[215]}zum Wurzelverzeichnis wechseln /*
* Copyright (c) 1998, 2022, Oracle and/or its affiliates. All rights reserved.
* DO NOT ALTER OR REMOVE COPYRIGHT NOTICES OR THIS FILE HEADER.
*
* This code is free software; you can redistribute it and/or modify it
* under the terms of the GNU General Public License version 2 only, as
* published by the Free Software Foundation. Oracle designates this
* particular file as subject to the "Classpath" exception as provided
* by Oracle in the LICENSE file that accompanied this code.
*
* This code is distributed in the hope that it will be useful, but WITHOUT
* ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
* FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
* version 2 for more details (a copy is included in the LICENSE file that
* accompanied this code).
*
* You should have received a copy of the GNU General Public License version
* 2 along with this work; if not, write to the Free Software Foundation,
* Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA.
*
* Please contact Oracle, 500 Oracle Parkway, Redwood Shores, CA 94065 USA
* or visit www.oracle.com if you need additional information or have any
* questions.
*/
JDWP "Java(tm) Debug Wire Protocol"
(CommandSet VirtualMachine=1
(Command Version=1
"Returns the JDWP version implemented by the target VM. "
"The version string format is implementation dependent. "
(Out
)
(Reply
(string description "Text information on the VM version")
(int jdwpMajor "Major JDWP Version number")
(int jdwpMinor "Minor JDWP Version number")
(string vmVersion "Target VM JRE version, as in the java.version property")
(string vmName "Target VM name, as in the java.vm.name property")
)
(ErrorSet
(Error VM_DEAD)
)
)
(Command ClassesBySignature=2
"Returns reference types for all the classes loaded by the target VM "
"which match the given signature. "
"Multple reference types will be returned if two or more class "
"loaders have loaded a class of the same name. "
"The search is confined to loaded classes only; no attempt is made "
"to load a class of the given signature. "
(Out
(string signature "JNI signature of the class to find "
"(for example, \"Ljava/lang/String;\"). "
)
)
(Reply
(Repeat classes "Number of reference types that follow."
(Group ClassInfo
(byte refTypeTag "#JDWP_TypeTag\">Kind "
"of following reference type. ")
(referenceTypeID typeID "Matching loaded reference type")
(int status "The current class "
"#JDWP_ClassStatus\">status. ")
)
)
)
(ErrorSet
(Error VM_DEAD)
)
)
(Command AllClasses=3
"Returns reference types for all classes currently loaded by the "
"target VM. "
"See ../jvmti.html#GetLoadedClasses\">JVM TI GetLoadedClasses."
(Out
)
(Reply
(Repeat classes "Number of reference types that follow."
(Group ClassInfo
(byte refTypeTag "#JDWP_TypeTag\">Kind "
"of following reference type. ")
(referenceTypeID typeID "Loaded reference type")
(string signature
"The JNI signature of the loaded reference type")
(int status "The current class "
"#JDWP_ClassStatus\">status. ")
)
)
)
(ErrorSet
(Error VM_DEAD)
)
)
(Command AllThreads=4
"Returns the live threads in the target VM. Threads that have not yet "
"started or threads that have terminated are not included in the list."
""
"The returned list contains a threadID for each live "
"platform thread "
"in the target VM. This includes platform threads created with the Thread "
"API and all native threads attached to the target VM with JNI code."
""
"It is implementation dependent if the list contains threadIDs for live "
"virtual threads "
"in the target VM. The target VM may not return threadIDs for virtual threads, "
"or it may be configured to return a threadID for some or all virtual threads."
(Out
)
(Reply
(Repeat threads "Number of threads that follow."
(threadObject thread "A running thread")
)
)
(ErrorSet
(Error VM_DEAD)
)
)
(Command TopLevelThreadGroups=5
"Returns all thread groups that do not have a parent. This command "
"may be used as the first step in building a tree (or trees) of the "
"existing thread groups."
(Out
)
(Reply
(Repeat groups "Number of thread groups that follow."
(threadGroupObject group "A top level thread group")
)
)
(ErrorSet
(Error VM_DEAD)
)
)
(Command Dispose=6
"Invalidates this virtual machine mirror. "
"The communication channel to the target VM is closed, and "
"the target VM prepares to accept another subsequent connection "
"from this debugger or another debugger, including the "
"following tasks: "
"
"All event requests are cancelled. "
"All threads suspended by the thread-level "
"#JDWP_ThreadReference_Suspend\">suspend command "
"or the VM-level "
"#JDWP_VirtualMachine_Suspend\">suspend command "
"are resumed as many times as necessary for them to run. "
"Garbage collection is re-enabled in all cases where it was "
"#JDWP_ObjectReference_DisableCollection\">disabled "
""
"Any current method invocations executing in the target VM "
"are continued after the disconnection. Upon completion of any such "
"method invocation, the invoking thread continues from the "
"location where it was originally stopped. "
""
"Resources originating in "
"this VirtualMachine (ObjectReferences, ReferenceTypes, etc.) "
"will become invalid. "
(Out
)
(Reply
)
(ErrorSet
)
)
(Command IDSizes=7
"Returns the sizes of variably-sized data types in the target VM."
"The returned values indicate the number of bytes used by the "
"identifiers in command and reply packets."
(Out
)
(Reply
(int fieldIDSize "fieldID size in bytes ")
(int methodIDSize "methodID size in bytes ")
(int objectIDSize "objectID size in bytes ")
(int referenceTypeIDSize "referenceTypeID size in bytes ")
(int frameIDSize "frameID size in bytes ")
)
(ErrorSet
(Error VM_DEAD)
)
)
(Command Suspend=8
"Suspends the execution of the application running in the target "
"VM. All Java threads currently running will be suspended. "
""
"Suspends of both the virtual machine and individual threads are "
"counted. Before a thread will run again, it must be resumed through "
"the #JDWP_VirtualMachine_Resume\">VM-level resume command "
"or the #JDWP_ThreadReference_Resume\">thread-level resume command "
"the same number of times it has been suspended. "
(Out
)
(Reply
)
(ErrorSet
(Error VM_DEAD)
)
)
(Command Resume=9
"Resumes execution of the application after the suspend "
"command or an event has stopped it. "
"Suspensions of the Virtual Machine and individual threads are "
"counted. If a particular thread is suspended n times, it must "
"resumed n times before it will continue. "
(Out
)
(Reply
)
(ErrorSet
)
)
(Command Exit=10
"Terminates the target VM with the given exit code. "
"On some platforms, the exit code might be truncated, for "
"example, to the low order 8 bits. "
"All ids previously returned from the target VM become invalid. "
"Threads running in the VM are abruptly terminated. "
"A thread death exception is not thrown and "
"finally blocks are not run."
(Out
(int exitCode "the exit code")
)
(Reply
)
(ErrorSet
)
)
(Command CreateString=11
"Creates a new string object in the target VM and returns "
"its id. "
(Out
(string utf "UTF-8 characters to use in the created string. ")
)
(Reply
(stringObject stringObject
"Created string (instance of java.lang.String) ")
)
(ErrorSet
(Error VM_DEAD)
)
)
(Command Capabilities=12
"Retrieve this VM's capabilities. The capabilities are returned "
"as booleans, each indicating the presence or absence of a "
"capability. The commands associated with each capability will "
"return the NOT_IMPLEMENTED error if the cabability is not "
"available."
(Out
)
(Reply
(boolean canWatchFieldModification
"Can the VM watch field modification, and therefore "
"can it send the Modification Watchpoint Event?")
(boolean canWatchFieldAccess
"Can the VM watch field access, and therefore "
"can it send the Access Watchpoint Event?")
(boolean canGetBytecodes
"Can the VM get the bytecodes of a given method? ")
(boolean canGetSyntheticAttribute
"Can the VM determine whether a field or method is "
"synthetic? (that is, can the VM determine if the "
"method or the field was invented by the compiler?) ")
(boolean canGetOwnedMonitorInfo
"Can the VM get the owned monitors infornation for "
"a thread?")
(boolean canGetCurrentContendedMonitor
"Can the VM get the current contended monitor of a thread?")
(boolean canGetMonitorInfo
"Can the VM get the monitor information for a given object? ")
)
(ErrorSet
(Error VM_DEAD)
)
)
(Command ClassPaths=13
"Retrieve the classpath and bootclasspath of the target VM. "
"If the classpath is not defined, returns an empty list. If the "
"bootclasspath is not defined returns an empty list."
(Out
)
(Reply
(string baseDir "Base directory used to resolve relative "
"paths in either of the following lists.")
(Repeat classpaths "Number of paths in classpath."
(string path "One component of classpath") )
(Repeat bootclasspaths "Number of paths in bootclasspath."
(string path "One component of bootclasspath") )
)
(ErrorSet
(Error VM_DEAD)
)
)
(Command DisposeObjects=14
"Releases a list of object IDs. For each object in the list, the "
"following applies. "
"The count of references held by the back-end (the reference "
"count) will be decremented by refCnt. "
"If thereafter the reference count is less than "
"or equal to zero, the ID is freed. "
"Any back-end resources associated with the freed ID may "
"be freed, and if garbage collection was "
"disabled for the object, it will be re-enabled. "
"The sender of this command "
"promises that no further commands will be sent "
"referencing a freed ID.
""
"Use of this command is not required. If it is not sent, "
"resources associated with each ID will be freed by the back-end "
"at some time after the corresponding object is garbage collected. "
"It is most useful to use this command to reduce the load on the "
"back-end if a very large number of "
"objects has been retrieved from the back-end (a large array, "
"for example) but may not be garbage collected any time soon. "
""
"IDs may be re-used by the back-end after they "
"have been freed with this command."
"This description assumes reference counting, "
"a back-end may use any implementation which operates "
"equivalently. "
(Out
(Repeat requests "Number of object dispose requests that follow"
(Group Request
(object object "The object ID")
(int refCnt "The number of times this object ID has been "
"part of a packet received from the back-end. "
"An accurate count prevents the object ID "
"from being freed on the back-end if "
"it is part of an incoming packet, not yet "
"handled by the front-end.")
)
)
)
(Reply
)
(ErrorSet
)
)
(Command HoldEvents=15
"Tells the target VM to stop sending events. Events are not discarded; "
"they are held until a subsequent ReleaseEvents command is sent. "
"This command is useful to control the number of events sent "
"to the debugger VM in situations where very large numbers of events "
"are generated. "
"While events are held by the debugger back-end, application "
"execution may be frozen by the debugger back-end to prevent "
"buffer overflows on the back end.
"Responses to commands are never held and are not affected by this
"command. If events are already being held, this command is "
"ignored."
(Out
)
(Reply
)
(ErrorSet
)
)
(Command ReleaseEvents=16
"Tells the target VM to continue sending events. This command is "
"used to restore normal activity after a HoldEvents command. If "
"there is no current HoldEvents command in effect, this command is "
"ignored."
(Out
)
(Reply
)
(ErrorSet
)
)
(Command CapabilitiesNew=17
"Retrieve all of this VM's capabilities. The capabilities are returned "
"as booleans, each indicating the presence or absence of a "
"capability. The commands associated with each capability will "
"return the NOT_IMPLEMENTED error if the cabability is not "
"available."
"Since JDWP version 1.4."
(Out
)
(Reply
(boolean canWatchFieldModification
"Can the VM watch field modification, and therefore "
"can it send the Modification Watchpoint Event?")
(boolean canWatchFieldAccess
"Can the VM watch field access, and therefore "
"can it send the Access Watchpoint Event?")
(boolean canGetBytecodes
"Can the VM get the bytecodes of a given method? ")
(boolean canGetSyntheticAttribute
"Can the VM determine whether a field or method is "
"synthetic? (that is, can the VM determine if the "
"method or the field was invented by the compiler?) ")
(boolean canGetOwnedMonitorInfo
"Can the VM get the owned monitors infornation for "
"a thread?")
(boolean canGetCurrentContendedMonitor
"Can the VM get the current contended monitor of a thread?")
(boolean canGetMonitorInfo
"Can the VM get the monitor information for a given object? ")
(boolean canRedefineClasses
"Can the VM redefine classes?")
(boolean canAddMethod
"Can the VM add methods when redefining classes? "
"@Deprecated(since=\" 15\") A JVM TI based JDWP back-end "
"will never set this capability to true.")
(boolean canUnrestrictedlyRedefineClasses
"Can the VM redefine classes "
"in ways that are normally restricted?"
"@Deprecated(since=\" 15\") A JVM TI based JDWP back-end "
"will never set this capability to true.")
(boolean canPopFrames
"Can the VM pop stack frames?")
(boolean canUseInstanceFilters
"Can the VM filter events by specific object?")
(boolean canGetSourceDebugExtension
"Can the VM get the source debug extension?")
(boolean canRequestVMDeathEvent
"Can the VM request VM death events?")
(boolean canSetDefaultStratum
"Can the VM set a default stratum?")
(boolean canGetInstanceInfo
"Can the VM return instances, counts of instances of classes "
"and referring objects?")
(boolean canRequestMonitorEvents
"Can the VM request monitor events?")
(boolean canGetMonitorFrameInfo
"Can the VM get monitors with frame depth info?")
(boolean canUseSourceNameFilters
"Can the VM filter class prepare events by source name?")
(boolean canGetConstantPool
"Can the VM return the constant pool information?")
(boolean canForceEarlyReturn
"Can the VM force early return from a method?")
(boolean reserved22
"Reserved for future capability")
(boolean reserved23
"Reserved for future capability")
(boolean reserved24
"Reserved for future capability")
(boolean reserved25
"Reserved for future capability")
(boolean reserved26
"Reserved for future capability")
(boolean reserved27
"Reserved for future capability")
(boolean reserved28
"Reserved for future capability")
(boolean reserved29
"Reserved for future capability")
(boolean reserved30
"Reserved for future capability")
(boolean reserved31
"Reserved for future capability")
(boolean reserved32
"Reserved for future capability")
)
(ErrorSet
(Error VM_DEAD)
)
)
(Command RedefineClasses=18
"Installs new class definitions. "
"If there are active stack frames in methods of the redefined classes in the "
"target VM then those active frames continue to run the bytecodes of the "
"original method. These methods are considered obsolete - see "
"#JDWP_Method_IsObsolete\">IsObsolete. The methods in the "
"redefined classes will be used for new invokes in the target VM. "
"The original method ID refers to the redefined method. "
"All breakpoints in the redefined classes are cleared."
"If resetting of stack frames is desired, the "
"#JDWP_StackFrame_PopFrames\">PopFrames command can be used "
"to pop frames with obsolete methods."
""
"Unless the canUnrestrictedlyRedefineClasses capability is present "
"the redefinition must follow the restrictions described in "
"../jvmti.html#RedefineClasses\">JVM TI RedefineClasses."
""
"Requires canRedefineClasses capability - see "
"#JDWP_VirtualMachine_CapabilitiesNew\">CapabilitiesNew. "
"@Deprecated(since=\" 15\") "
"In addition to the canRedefineClasses capability, the target VM must "
"have the canAddMethod capability to add methods when redefining classes, "
"or the canUnrestrictedlyRedefineClasses capability to redefine classes in ways "
"that are normally restricted."
(Out
(Repeat classes "Number of reference types that follow."
(Group ClassDef
(referenceType refType "The reference type.")
(Repeat classfile "Number of bytes defining class (below)"
(byte classbyte "byte in JVM class file "
"format.")
)
)
)
)
(Reply
)
(ErrorSet
(Error INVALID_CLASS "One of the refTypes is not the ID of a reference "
"type.")
(Error INVALID_OBJECT "One of the refTypes is not a known ID.")
(Error UNSUPPORTED_VERSION)
(Error INVALID_CLASS_FORMAT)
(Error CIRCULAR_CLASS_DEFINITION)
(Error FAILS_VERIFICATION)
(Error NAMES_DONT_MATCH)
(Error NOT_IMPLEMENTED "No aspect of this functionality is implemented "
"(CapabilitiesNew.canRedefineClasses is false)")
(Error ADD_METHOD_NOT_IMPLEMENTED)
(Error SCHEMA_CHANGE_NOT_IMPLEMENTED)
(Error HIERARCHY_CHANGE_NOT_IMPLEMENTED)
(Error DELETE_METHOD_NOT_IMPLEMENTED)
(Error CLASS_MODIFIERS_CHANGE_NOT_IMPLEMENTED)
(Error METHOD_MODIFIERS_CHANGE_NOT_IMPLEMENTED)
(Error CLASS_ATTRIBUTE_CHANGE_NOT_IMPLEMENTED)
(Error VM_DEAD)
)
)
(Command SetDefaultStratum=19
"Set the default stratum. Requires canSetDefaultStratum capability - see "
"#JDWP_VirtualMachine_CapabilitiesNew\">CapabilitiesNew."
(Out
(string stratumID "default stratum, or empty string to use "
"reference type default.")
)
(Reply
)
(ErrorSet
(Error NOT_IMPLEMENTED)
(Error VM_DEAD)
)
)
(Command AllClassesWithGeneric=20
"Returns reference types for all classes currently loaded by the "
"target VM. "
"Both the JNI signature and the generic signature are "
"returned for each class. "
"Generic signatures are described in the signature attribute "
"section in "
"The Java Virtual Machine Specification. "
"Since JDWP version 1.5."
(Out
)
(Reply
(Repeat classes "Number of reference types that follow."
(Group ClassInfo
(byte refTypeTag "#JDWP_TypeTag\">Kind "
"of following reference type. ")
(referenceTypeID typeID "Loaded reference type")
(string signature
"The JNI signature of the loaded reference type.")
(string genericSignature
"The generic signature of the loaded reference type "
"or an empty string if there is none.")
(int status "The current class "
"#JDWP_ClassStatus\">status. ")
)
)
)
(ErrorSet
(Error VM_DEAD)
)
)
(Command InstanceCounts=21
"Returns the number of instances of each reference type in the input list. "
"Only instances that are reachable for the purposes of "
"garbage collection are counted. If a reference type is invalid, "
"eg. it has been unloaded, zero is returned for its instance count."
"Since JDWP version 1.6. Requires canGetInstanceInfo capability - see "
"#JDWP_VirtualMachine_CapabilitiesNew\">CapabilitiesNew."
(Out
(Repeat refTypesCount "Number of reference types that follow. Must be non-negative."
(referenceType refType "A reference type ID.")
)
)
(Reply
(Repeat counts "The number of counts that follow."
(long instanceCount "The number of instances for the corresponding reference type "
"in 'Out Data'.")
)
)
(ErrorSet
(Error ILLEGAL_ARGUMENT "refTypesCount is less than zero.")
(Error NOT_IMPLEMENTED)
(Error VM_DEAD)
)
)
(Command AllModules=22
"Returns all modules in the target VM."
"Since JDWP version 9."
(Out
)
(Reply
(Repeat modules "The number of the modules that follow."
(moduleID module "One of the modules.")
)
)
(ErrorSet
(Error NOT_IMPLEMENTED)
(Error VM_DEAD)
)
)
)
(CommandSet ReferenceType=2
(Command Signature=1
"Returns the type signature of a reference type. "
"Type signature formats are the same as specified in "
"../jvmti.html#GetClassSignature\">JVM TI GetClassSignature."
(Out
(referenceType refType "The reference type ID.")
)
(Reply
(string signature
"The JNI signature for the reference type.")
)
(ErrorSet
(Error INVALID_CLASS "refType is not the ID of a reference "
"type.")
(Error INVALID_OBJECT "refType is not a known ID.")
(Error VM_DEAD)
)
)
(Command ClassLoader=2
"Returns the instance of java.lang.ClassLoader which loaded "
"a given reference type. If the reference type was loaded by the "
"system class loader, the returned object ID is null."
(Out
(referenceType refType "The reference type ID.")
)
(Reply
(classLoaderObject classLoader "The class loader for the reference type. ")
)
(ErrorSet
(Error INVALID_CLASS "refType is not the ID of a reference "
"type.")
(Error INVALID_OBJECT "refType is not a known ID.")
(Error VM_DEAD)
)
)
(Command Modifiers=3
"Returns the modifiers (also known as access flags) for a reference type. "
"The returned bit mask contains information on the declaration "
"of the reference type. If the reference type is an array or "
"a primitive class (for example, java.lang.Integer.TYPE), the "
"value of the returned bit mask is undefined."
(Out
(referenceType refType "The reference type ID.")
)
(Reply
(int modBits "Modifier bits as defined in Chapter 4 of "
"The Java Virtual Machine Specification")
)
(ErrorSet
(Error INVALID_CLASS "refType is not the ID of a reference "
"type.")
(Error INVALID_OBJECT "refType is not a known ID.")
(Error VM_DEAD)
)
)
(Command Fields=4
"Returns information for each field in a reference type. "
"Inherited fields are not included. "
"The field list will include any synthetic fields created "
"by the compiler. "
"Fields are returned in the order they occur in the class file."
(Out
(referenceType refType "The reference type ID.")
)
(Reply
(Repeat declared "Number of declared fields."
(Group FieldInfo
(field fieldID "Field ID.")
(string name "Name of field.")
(string signature "JNI Signature of field.")
(int modBits "The modifier bit flags (also known as access flags) "
"which provide additional information on the "
"field declaration. Individual flag values are "
"defined in Chapter 4 of "
"The Java Virtual Machine Specification. "
"In addition, The 0xf0000000 bit identifies "
"the field as synthetic, if the synthetic attribute "
"#JDWP_VirtualMachine_Capabilities\">capability is available.")
)
)
)
(ErrorSet
(Error CLASS_NOT_PREPARED)
(Error INVALID_CLASS "refType is not the ID of a reference "
"type.")
(Error INVALID_OBJECT "refType is not a known ID.")
(Error VM_DEAD)
)
)
(Command Methods=5
"Returns information for each method in a reference type. "
"Inherited methods are not included. The list of methods will "
"include constructors (identified with the name \"<init>\"), "
"the initialization method (identified with the name \"<clinit>\") "
"if present, and any synthetic methods created by the compiler. "
"Methods are returned in the order they occur in the class file."
(Out
(referenceType refType "The reference type ID.")
)
(Reply
(Repeat declared "Number of declared methods."
(Group MethodInfo
(method methodID "Method ID.")
(string name "Name of method.")
(string signature "JNI signature of method.")
(int modBits "The modifier bit flags (also known as access flags) "
"which provide additional information on the "
"method declaration. Individual flag values are "
"defined in Chapter 4 of "
"The Java Virtual Machine Specification. "
"In addition, The 0xf0000000 bit identifies "
"the method as synthetic, if the synthetic attribute "
"#JDWP_VirtualMachine_Capabilities\">capability is available.")
)
)
)
(ErrorSet
(Error CLASS_NOT_PREPARED)
(Error INVALID_CLASS "refType is not the ID of a reference "
"type.")
(Error INVALID_OBJECT "refType is not a known ID.")
(Error VM_DEAD)
)
)
(Command GetValues=6
"Returns the value of one or more static fields of the "
"reference type. Each field must be member of the reference type "
"or one of its superclasses, superinterfaces, or implemented interfaces. "
"Access control is not enforced; for example, the values of private "
"fields can be obtained."
(Out
(referenceType refType "The reference type ID.")
(Repeat fields "The number of values to get"
(Group Field
(field fieldID "A field to get")
)
)
)
(Reply
(Repeat values "The number of values returned, always equal to fields, "
"the number of values to get."
(value value "The field value")
)
)
(ErrorSet
(Error INVALID_CLASS "refType is not the ID of a reference "
"type.")
(Error INVALID_OBJECT "refType is not a known ID.")
(Error INVALID_FIELDID)
(Error VM_DEAD)
)
)
(Command SourceFile=7
"Returns the name of source file in which a reference type was "
"declared. "
(Out
(referenceType refType "The reference type ID.")
)
(Reply
(string sourceFile "The source file name. No path information "
"for the file is included")
)
(ErrorSet
(Error INVALID_CLASS "refType is not the ID of a reference "
"type.")
(Error INVALID_OBJECT "refType is not a known ID.")
(Error ABSENT_INFORMATION "The source file attribute is absent.")
(Error VM_DEAD)
)
)
(Command NestedTypes=8
"Returns the classes and interfaces directly nested within this type."
"Types further nested within those types are not included. "
(Out
(referenceType refType "The reference type ID.")
)
(Reply
(Repeat classes "The number of nested classes and interfaces"
(Group TypeInfo
(byte refTypeTag "#JDWP_TypeTag\">Kind "
"of following reference type. ")
(referenceTypeID typeID "The nested class or interface ID.")
)
)
)
(ErrorSet
(Error INVALID_CLASS "refType is not the ID of a reference "
"type.")
(Error INVALID_OBJECT "refType is not a known ID.")
(Error VM_DEAD)
)
)
(Command Status=9
"Returns the current status of the reference type. The status "
"indicates the extent to which the reference type has been "
"initialized, as described in section 2.1.6 of "
"The Java Virtual Machine Specification. "
"If the class is linked the PREPARED and VERIFIED bits in the returned status bits "
"will be set. If the class is initialized the INITIALIZED bit in the returned "
"status bits will be set. If an error occured during initialization then the "
"ERROR bit in the returned status bits will be set. "
"The returned status bits are undefined for array types and for "
"primitive classes (such as java.lang.Integer.TYPE). "
(Out
(referenceType refType "The reference type ID.")
)
(Reply
(int status "#JDWP_ClassStatus\">Status bits:"
"See #JDWP_ClassStatus\">JDWP.ClassStatus")
)
(ErrorSet
(Error INVALID_CLASS "refType is not the ID of a reference "
"type.")
(Error INVALID_OBJECT "refType is not a known ID.")
(Error VM_DEAD)
)
)
(Command Interfaces=10
"Returns the interfaces declared as implemented by this class. "
"Interfaces indirectly implemented (extended by the implemented "
"interface or implemented by a superclass) are not included."
(Out
(referenceType refType "The reference type ID.")
)
(Reply
(Repeat interfaces "The number of implemented interfaces"
(interfaceType interfaceType "implemented interface.")
)
)
(ErrorSet
(Error INVALID_CLASS "refType is not the ID of a reference "
"type.")
(Error INVALID_OBJECT "refType is not a known ID.")
(Error VM_DEAD)
)
)
(Command ClassObject=11
"Returns the class object corresponding to this type. "
(Out
(referenceType refType "The reference type ID.")
)
(Reply
(classObject classObject "class object.")
)
(ErrorSet
(Error INVALID_CLASS "refType is not the ID of a reference "
"type.")
(Error INVALID_OBJECT "refType is not a known ID.")
(Error VM_DEAD)
)
)
(Command SourceDebugExtension=12
"Returns the value of the SourceDebugExtension attribute. "
"Since JDWP version 1.4. Requires canGetSourceDebugExtension capability - see "
"#JDWP_VirtualMachine_CapabilitiesNew\">CapabilitiesNew."
(Out
(referenceType refType "The reference type ID.")
)
(Reply
(string extension "extension attribute")
)
(ErrorSet
(Error INVALID_CLASS "refType is not the ID of a reference "
"type.")
(Error INVALID_OBJECT "refType is not a known ID.")
(Error ABSENT_INFORMATION "If the extension is not specified.")
(Error NOT_IMPLEMENTED)
(Error VM_DEAD)
)
)
(Command SignatureWithGeneric=13
"Returns the JNI signature of a reference type along with the "
"generic signature if there is one. "
"Generic signatures are described in the signature attribute "
"section in "
"The Java Virtual Machine Specification. "
"Since JDWP version 1.5."
(Out
(referenceType refType "The reference type ID.")
)
(Reply
(string signature
"The JNI signature for the reference type.")
(string genericSignature
"The generic signature for the reference type or an empty "
"string if there is none.")
)
(ErrorSet
(Error INVALID_CLASS "refType is not the ID of a reference "
"type.")
(Error INVALID_OBJECT "refType is not a known ID.")
(Error VM_DEAD)
)
)
(Command FieldsWithGeneric=14
"Returns information, including the generic signature if any, "
"for each field in a reference type. "
"Inherited fields are not included. "
"The field list will include any synthetic fields created "
"by the compiler. "
"Fields are returned in the order they occur in the class file. "
"Generic signatures are described in the signature attribute "
"section in "
"The Java Virtual Machine Specification. "
"Since JDWP version 1.5."
(Out
(referenceType refType "The reference type ID.")
)
(Reply
(Repeat declared "Number of declared fields."
(Group FieldInfo
(field fieldID "Field ID.")
(string name "The name of the field.")
(string signature "The JNI signature of the field.")
(string genericSignature "The generic signature of the "
"field, or an empty string if there is none.")
(int modBits "The modifier bit flags (also known as access flags) "
"which provide additional information on the "
"field declaration. Individual flag values are "
"defined in Chapter 4 of "
"The Java Virtual Machine Specification. "
"In addition, The 0xf0000000 bit identifies "
"the field as synthetic, if the synthetic attribute "
"#JDWP_VirtualMachine_Capabilities\">capability is available.")
)
)
)
(ErrorSet
(Error CLASS_NOT_PREPARED)
(Error INVALID_CLASS "refType is not the ID of a reference "
"type.")
(Error INVALID_OBJECT "refType is not a known ID.")
(Error VM_DEAD)
)
)
(Command MethodsWithGeneric=15
"Returns information, including the generic signature if any, "
"for each method in a reference type. "
"Inherited methodss are not included. The list of methods will "
"include constructors (identified with the name \"<init>\"), "
"the initialization method (identified with the name \"<clinit>\") "
"if present, and any synthetic methods created by the compiler. "
"Methods are returned in the order they occur in the class file. "
"Generic signatures are described in the signature attribute "
"section in "
"The Java Virtual Machine Specification. "
"Since JDWP version 1.5."
(Out
(referenceType refType "The reference type ID.")
)
(Reply
(Repeat declared "Number of declared methods."
(Group MethodInfo
(method methodID "Method ID.")
(string name "The name of the method.")
(string signature "The JNI signature of the method.")
(string genericSignature "The generic signature of the method, or "
"an empty string if there is none.")
(int modBits "The modifier bit flags (also known as access flags) "
"which provide additional information on the "
"method declaration. Individual flag values are "
"defined in Chapter 4 of "
"The Java Virtual Machine Specification. "
"In addition, The 0xf0000000 bit identifies "
"the method as synthetic, if the synthetic attribute "
"#JDWP_VirtualMachine_Capabilities\">capability is available.")
)
)
)
(ErrorSet
(Error CLASS_NOT_PREPARED)
(Error INVALID_CLASS "refType is not the ID of a reference "
"type.")
(Error INVALID_OBJECT "refType is not a known ID.")
(Error VM_DEAD)
)
)
(Command Instances=16
"Returns instances of this reference type. "
"Only instances that are reachable for the purposes of "
"garbage collection are returned. "
"Since JDWP version 1.6. Requires canGetInstanceInfo capability - see "
"#JDWP_VirtualMachine_CapabilitiesNew\">CapabilitiesNew."
(Out
(referenceType refType "The reference type ID.")
(int maxInstances "Maximum number of instances to return. Must be non-negative. "
"If zero, all instances are returned.")
)
(Reply
(Repeat instances "The number of instances that follow."
(tagged-object instance "An instance of this reference type.")
)
)
(ErrorSet
(Error INVALID_CLASS "refType is not the ID of a reference "
"type.")
(Error INVALID_OBJECT "refType is not a known ID.")
(Error ILLEGAL_ARGUMENT "maxInstances is less than zero.")
(Error NOT_IMPLEMENTED)
(Error VM_DEAD)
)
)
(Command ClassFileVersion=17
"Returns the class file major and minor version numbers, as defined in the class "
"file format of the Java Virtual Machine specification. "
"Since JDWP version 1.6. "
(Out
(referenceType refType "The class.")
)
(Reply
(int majorVersion "Major version number")
(int minorVersion "Minor version number")
)
(ErrorSet
(Error INVALID_CLASS "refType is not the ID of a reference "
"type.")
(Error INVALID_OBJECT "refType is not a known ID.")
(Error ABSENT_INFORMATION "The class file version information is "
"absent for primitive and array types.")
(Error VM_DEAD)
)
)
(Command ConstantPool=18
"Return the raw bytes of the constant pool in the format of the "
"constant_pool item of the Class File Format in "
"The Java Virtual Machine Specification. "
"Since JDWP version 1.6. Requires canGetConstantPool capability - see "
"#JDWP_VirtualMachine_CapabilitiesNew\">CapabilitiesNew.""
(Out
(referenceType refType "The class.")
)
(Reply
(int count "Total number of constant pool entries plus one. This "
"corresponds to the constant_pool_count item of the "
"Class File Format in "
"The Java Virtual Machine Specification. ")
(Repeat bytes
(byte cpbytes "Raw bytes of constant pool")
)
)
(ErrorSet
(Error INVALID_CLASS "refType is not the ID of a reference "
"type.")
(Error INVALID_OBJECT "refType is not a known ID.")
(Error NOT_IMPLEMENTED "If the target virtual machine does not "
"support the retrieval of constant pool information.")
(Error ABSENT_INFORMATION "The Constant Pool information is "
"absent for primitive and array types.")
(Error VM_DEAD)
)
)
(Command Module=19
"Returns the module that this reference type belongs to."
"Since JDWP version 9."
(Out
(referenceType refType "The reference type.")
)
(Reply
(moduleID module "The module this reference type belongs to.")
)
(ErrorSet
(Error INVALID_CLASS "refType is not the ID of a reference type.")
(Error INVALID_OBJECT "refType is not a known ID.")
(Error NOT_IMPLEMENTED)
(Error VM_DEAD)
)
)
)
(CommandSet ClassType=3
(Command Superclass=1
"Returns the immediate superclass of a class."
(Out
(classType clazz "The class type ID.")
)
(Reply
(classType superclass
"The superclass (null if the class ID for java.lang.Object is specified).")
)
(ErrorSet
(Error INVALID_CLASS "clazz is not the ID of a class.")
(Error INVALID_OBJECT "clazz is not a known ID.")
(Error VM_DEAD)
)
)
(Command SetValues=2
"Sets the value of one or more static fields. "
"Each field must be member of the class type "
"or one of its superclasses, superinterfaces, or implemented interfaces. "
"Access control is not enforced; for example, the values of private "
"fields can be set. Final fields cannot be set."
"For primitive values, the value's type must match the "
"field's type exactly. For object values, there must exist a "
"widening reference conversion from the value's type to the
"field's type and the field's type must be loaded. "
(Out
(classType clazz "The class type ID.")
(Repeat values "The number of fields to set."
(Group FieldValue "A Field/Value pair."
(field fieldID "Field to set.")
(untagged-value value "Value to put in the field.")
)
)
)
(Reply "none"
)
(ErrorSet
(Error INVALID_CLASS "clazz is not the ID of a class.")
(Error CLASS_NOT_PREPARED)
(Error INVALID_OBJECT "clazz is not a known ID or a value of an "
"object field is not a known ID.")
(Error INVALID_FIELDID)
(Error VM_DEAD)
)
)
(Command InvokeMethod=3
"Invokes a static method. "
"The method must be member of the class type "
"or one of its superclasses. "
"Access control is not enforced; for example, private "
"methods can be invoked."
""
"The method invocation will occur in the specified thread. "
"Method invocation can occur only if the specified thread "
"has been suspended by an event. "
"Method invocation is not supported "
"when the target VM has been suspended by the front-end. "
""
"The specified method is invoked with the arguments in the specified "
"argument list. "
"The method invocation is synchronous; the reply packet is not "
"sent until the invoked method returns in the target VM. "
"The return value (possibly the void value) is "
"included in the reply packet. "
"If the invoked method throws an exception, the "
"exception object ID is set in the reply packet; otherwise, the "
"exception object ID is null. "
""
"For primitive arguments, the argument value's type must match the "
"argument's type exactly. For object arguments, there must exist a "
"widening reference conversion from the argument value's type to the "
"argument's type and the argument's type must be loaded. "
""
"By default, all threads in the target VM are resumed while "
"the method is being invoked if they were previously "
"suspended by an event or by command. "
"This is done to prevent the deadlocks "
"that will occur if any of the threads own monitors "
"that will be needed by the invoked method. It is possible that "
"breakpoints or other events might occur during the invocation. "
"Note, however, that this implicit resume acts exactly like "
"the ThreadReference resume command, so if the thread's suspend "
"count is greater than 1, it will remain in a suspended state "
"during the invocation. By default, when the invocation completes, "
"all threads in the target VM are suspended, regardless their state "
"before the invocation. "
""
"The resumption of other threads during the invoke can be prevented "
"by specifying the INVOKE_SINGLE_THREADED "
"bit flag in the options field; however, "
"there is no protection against or recovery from the deadlocks "
"described above, so this option should be used with great caution. "
"Only the specified thread will be resumed (as described for all "
"threads above). Upon completion of a single threaded invoke, the invoking thread "
"will be suspended once again. Note that any threads started during "
"the single threaded invocation will not be suspended when the "
"invocation completes. "
""
"If the target VM is disconnected during the invoke (for example, through "
"the VirtualMachine dispose command) the method invocation continues. "
(Out
(classType clazz "The class type ID.")
(threadObject thread "The thread in which to invoke.")
(method methodID "The method to invoke.")
(Repeat arguments
(value arg "The argument value.")
)
(int options "Invocation #JDWP_InvokeOptions\">options")
)
(Reply
(value returnValue "The returned value.")
(tagged-object exception "The thrown exception.")
)
(ErrorSet
(Error INVALID_CLASS "clazz is not the ID of a class.")
(Error INVALID_OBJECT "clazz is not a known ID.")
(Error INVALID_METHODID "methodID is not the ID of a static method in "
"this class type or one of its superclasses.")
(Error INVALID_THREAD)
(Error THREAD_NOT_SUSPENDED)
(Error VM_DEAD)
)
)
(Command NewInstance=4
"Creates a new object of this type, invoking the specified "
"constructor. The constructor method ID must be a member of "
"the class type."
""
"Instance creation will occur in the specified thread. "
"Instance creation can occur only if the specified thread "
"has been suspended by an event. "
"Method invocation is not supported "
"when the target VM has been suspended by the front-end. "
""
"The specified constructor is invoked with the arguments in the specified "
"argument list. "
"The constructor invocation is synchronous; the reply packet is not "
"sent until the invoked method returns in the target VM. "
"The return value (possibly the void value) is "
"included in the reply packet. "
"If the constructor throws an exception, the "
"exception object ID is set in the reply packet; otherwise, the "
"exception object ID is null. "
""
"For primitive arguments, the argument value's type must match the "
"argument's type exactly. For object arguments, there must exist a "
"widening reference conversion from the argument value's type to the "
"argument's type and the argument's type must be loaded. "
""
"By default, all threads in the target VM are resumed while "
"the method is being invoked if they were previously "
"suspended by an event or by command. "
"This is done to prevent the deadlocks "
"that will occur if any of the threads own monitors "
"that will be needed by the invoked method. It is possible that "
"breakpoints or other events might occur during the invocation. "
"Note, however, that this implicit resume acts exactly like "
"the ThreadReference resume command, so if the thread's suspend "
"count is greater than 1, it will remain in a suspended state "
"during the invocation. By default, when the invocation completes, "
"all threads in the target VM are suspended, regardless their state "
"before the invocation. "
""
"The resumption of other threads during the invoke can be prevented "
"by specifying the INVOKE_SINGLE_THREADED "
"bit flag in the options field; however, "
"there is no protection against or recovery from the deadlocks "
"described above, so this option should be used with great caution. "
"Only the specified thread will be resumed (as described for all "
"threads above). Upon completion of a single threaded invoke, the invoking thread "
"will be suspended once again. Note that any threads started during "
"the single threaded invocation will not be suspended when the "
"invocation completes. "
""
"If the target VM is disconnected during the invoke (for example, through "
"the VirtualMachine dispose command) the method invocation continues. "
(Out
(classType clazz "The class type ID.")
(threadObject thread "The thread in which to invoke the constructor.")
(method methodID "The constructor to invoke.")
(Repeat arguments
(value arg "The argument value.")
)
(int options "Constructor invocation #JDWP_InvokeOptions\">options")
)
(Reply
(tagged-object newObject "The newly created object, or null "
"if the constructor threw an exception.")
(tagged-object exception "The thrown exception, if any; otherwise, null.")
)
(ErrorSet
(Error INVALID_CLASS "clazz is not the ID of a class.")
(Error INVALID_OBJECT "clazz is not a known ID or a value of an "
"object parameter is not a known ID..")
(Error INVALID_METHODID "methodID is not the ID of a method.")
(Error INVALID_OBJECT)
(Error INVALID_THREAD)
(Error THREAD_NOT_SUSPENDED)
(Error VM_DEAD)
)
)
)
(CommandSet ArrayType=4
(Command NewInstance=1
"Creates a new array object of this type with a given length."
(Out
(arrayType arrType "The array type of the new instance.")
(int length "The length of the array.")
)
(Reply
(tagged-object newArray "The newly created array object. ")
)
(ErrorSet
(Error INVALID_ARRAY)
(Error INVALID_OBJECT)
(Error VM_DEAD)
)
)
)
(CommandSet InterfaceType=5
(Command InvokeMethod=1
"Invokes a static method. "
"The method must not be a static initializer. "
"The method must be a member of the interface type. "
"Since JDWP version 1.8 "
""
"The method invocation will occur in the specified thread. "
"Method invocation can occur only if the specified thread "
"has been suspended by an event. "
"Method invocation is not supported "
"when the target VM has been suspended by the front-end. "
""
"The specified method is invoked with the arguments in the specified "
"argument list. "
"The method invocation is synchronous; the reply packet is not "
"sent until the invoked method returns in the target VM. "
"The return value (possibly the void value) is "
"included in the reply packet. "
"If the invoked method throws an exception, the "
"exception object ID is set in the reply packet; otherwise, the "
"exception object ID is null. "
""
"For primitive arguments, the argument value's type must match the "
"argument's type exactly. For object arguments, there must exist a "
"widening reference conversion from the argument value's type to the "
"argument's type and the argument's type must be loaded. "
""
"By default, all threads in the target VM are resumed while "
"the method is being invoked if they were previously "
"suspended by an event or by a command. "
"This is done to prevent the deadlocks "
"that will occur if any of the threads own monitors "
"that will be needed by the invoked method. It is possible that "
"breakpoints or other events might occur during the invocation. "
"Note, however, that this implicit resume acts exactly like "
"the ThreadReference resume command, so if the thread's suspend "
"count is greater than 1, it will remain in a suspended state "
"during the invocation. By default, when the invocation completes, "
"all threads in the target VM are suspended, regardless their state "
"before the invocation. "
""
"The resumption of other threads during the invoke can be prevented "
"by specifying the INVOKE_SINGLE_THREADED "
"bit flag in the options field; however, "
"there is no protection against or recovery from the deadlocks "
"described above, so this option should be used with great caution. "
"Only the specified thread will be resumed (as described for all "
"threads above). Upon completion of a single threaded invoke, the invoking thread "
"will be suspended once again. Note that any threads started during "
"the single threaded invocation will not be suspended when the "
"invocation completes. "
""
"If the target VM is disconnected during the invoke (for example, through "
"the VirtualMachine dispose command) the method invocation continues. "
(Out
(interfaceType clazz "The interface type ID.")
(threadObject thread "The thread in which to invoke.")
(method methodID "The method to invoke.")
(Repeat arguments
(value arg "The argument value.")
)
(int options "Invocation #JDWP_InvokeOptions\">options")
)
(Reply
(value returnValue "The returned value.")
(tagged-object exception "The thrown exception.")
)
(ErrorSet
(Error INVALID_CLASS "clazz is not the ID of an interface.")
(Error INVALID_OBJECT "clazz is not a known ID.")
(Error INVALID_METHODID "methodID is not the ID of a static method in this "
"interface type or is the ID of a static initializer.")
(Error INVALID_THREAD)
(Error THREAD_NOT_SUSPENDED)
(Error VM_DEAD)
)
)
)
(CommandSet Method=6
(Command LineTable=1
"Returns line number information for the method, if present. "
"The line table maps source line numbers to the initial code index "
"of the line. The line table "
"is ordered by code index (from lowest to highest). The line number "
"information is constant unless a new class definition is installed "
"using #JDWP_VirtualMachine_RedefineClasses\">RedefineClasses."
(Out
(referenceType refType "The class.")
(method methodID "The method.")
)
(Reply
(long start "Lowest valid code index for the method, >=0, or -1 if the method is native ")
(long end "Highest valid code index for the method, >=0, or -1 if the method is native")
(Repeat lines "The number of entries in the line table for this method."
(Group LineInfo
(long lineCodeIndex "Initial code index of the line, "
"start <= lineCodeIndex < end")
(int lineNumber "Line number.")
)
)
)
(ErrorSet
(Error INVALID_CLASS "refType is not the ID of a reference "
"type.")
(Error INVALID_OBJECT "refType is not a known ID.")
(Error INVALID_METHODID "methodID is not the ID of a method.")
(Error VM_DEAD)
)
)
(Command VariableTable=2
"Returns variable information for the method. The variable table "
"includes arguments and locals declared within the method. For "
"instance methods, the \"this\" reference is included in the "
"table. Also, synthetic variables may be present. "
(Out
(referenceType refType "The class.")
(method methodID "The method.")
)
(Reply
(int argCnt "The number of words in the frame used by arguments. "
"Eight-byte arguments use two words; all others use one. ")
(Repeat slots "The number of variables."
(Group SlotInfo "Information about the variable."
(long codeIndex
"First code index at which the variable is visible (unsigned). "
"Used in conjunction with length . "
"The variable can be get or set only when the current "
"codeIndex <= current frame code index < codeIndex + length ")
(string name "The variable's name.")
(string signature "The variable type's JNI signature.")
(int length
"Unsigned value used in conjunction with codeIndex . "
"The variable can be get or set only when the current "
"codeIndex <= current frame code index < code index + length ")
(int slot "The local variable's index in its frame")
)
)
)
(ErrorSet
--> --------------------
--> maximum size reached
--> --------------------
[ zur Elbe Produktseite wechseln0.206Quellennavigators
]
|
|