[options-not-recognized-by-mariadbd]
alter_algorithm=invalid
alter_algorithm=impossible
alter_algorithm=impossible2
#
# Testing --edit=last --from=mysql
# This will fail and changes will be reverted
#
[mysqld]
invalid=true
invalid_option
[mysqld-5.7]
audit_log=ON
audit_log_file=name
#
# Testing audit_log part 3
#
[mysqld]
audit_log-disabled
Warning: Please replace audit_log with the server_audit plugin
Updated files:
MYSQLTEST_VARDIR/tmp/tmp1.cnf 2 issue/issues fixed
[mariadbd]
skip_slave_start
[mysqld-5.7]
audit_log-disabled
#
# Testing comments
#
[mysqld]
character_set_server = utf8mb4 # It's a new world
collation_server = utf8mb4_0900_ai_ci
log_error_verbosity = 3
Updated files:
MYSQLTEST_VARDIR/tmp/tmp1.cnf 2 issue/issues fixed
[mysqld]
character_set_server = utf8mb4 # It's a new world
collation_server = utf8mb4_0900_ai_ci
[mariadbd]
skip_slave_start
[mysqld-5.7]
log_error_verbosity = 3
#
# Testing --fix-all
#
[mysqld]
innodb_data_file_path=/var/mysql/test2
key_buffer_size=20M
Note: 'aria_pagecache_buffer_size=20M' added to [mariadbd] group
Note: Added MySQL default character sets and collation to [mariadbd] to be able to replicate to MySQL
Updated files:
MYSQLTEST_VARDIR/tmp/tmp1.cnf 17 issue/issues fixed
[mysqld]
innodb_data_file_path=/var/mysql/test2
[mariadbd]
key_buffer_size=64K # Recommended value if no MyISAM tables
aria_pagecache_buffer_size=20M
skip_slave_start
# The following options enable MariaDB to replicate to MySQL
encrypt_binlog=0
log_bin_compress=0
# Not required, but recommended for cross_replication
binlog_format=row
# Character set to be able to replicate new tables to MySQL 8.0
character_set_server=utf8mb4
collation_server=utf8mb4_0900_ai_ci
[mysqld-5.7]
key_buffer_size=20M
# The following options enable MySQL to replicate to MariaDB
loose-binlog_row_value_options=""
loose-binlog_transaction_compression=0
# Not required, but recommended for cross_replication
binlog_format=row
#
# Testing --fix-all --update-paths
#
[mysqld]
innodb_data_file_path=/var/mysql/test2
key_buffer_size=20M
Note: 'aria_pagecache_buffer_size=20M' added to [mariadbd] group
Note: Added MySQL default character sets and collation to [mariadbd] to be able to replicate to MySQL
Updated files:
MYSQLTEST_VARDIR/tmp/tmp1.cnf 19 issue/issues fixed
[mariadbd]
innodb_data_file_path=/var/mariadb/test2
key_buffer_size=64K # Recommended value if no MyISAM tables
aria_pagecache_buffer_size=20M
skip_slave_start
# The following options enable MariaDB to replicate to MySQL
encrypt_binlog=0
log_bin_compress=0
# Not required, but recommended for cross_replication
binlog_format=row
# Character set to be able to replicate new tables to MySQL 8.0
character_set_server=utf8mb4
collation_server=utf8mb4_0900_ai_ci
[mysqld-5.7]
innodb_data_file_path=/var/mysql/test2
key_buffer_size=20M
# The following options enable MySQL to replicate to MariaDB
loose-binlog_row_value_options=""
loose-binlog_transaction_compression=0
# Not required, but recommended for cross_replication
binlog_format=row
#
# Testing path copying, without error-group and silent
#
[mysqld]
innodb_data_file_path=/var/mysql/test
port=38
dummy=/var/mysql/test
log-error=/var/mysql/test2
[mysqld-8.0]
port=39
dummy2=2
innodb_data_file_path=/var/mysql/test2
In MYSQLTEST_VARDIR/tmp/tmp1.cnf at line 2: 'innodb_data_file_path=/var/mysql/test' would be replaced with 'innodb_data_file_path=/var/mariadb/test'
In MYSQLTEST_VARDIR/tmp/tmp1.cnf at line 4: Invalid option dummy
In MYSQLTEST_VARDIR/tmp/tmp1.cnf at line 5: 'log-error=/var/mysql/test2' would be replaced with 'log-error=/var/mariadb/test2'
In MYSQLTEST_VARDIR/tmp/tmp1.cnf at line 10: 'innodb_data_file_path=/var/mysql/test2'would be replaced with 'innodb_data_file_path=/var/mariadb/test2' 2 line/lines would be copied to [mariadbd] group 5 line/lines would be copied to [mysqld-5.7] group 11 issue/issues found
MYSQLTEST_VARDIR/tmp/tmp1.cnf
# Changed file
[mysqld]
port=38
In MYSQLTEST_VARDIR/tmp/tmp1.cnf at line 2: 'innodb_stats_sample_pages=1' would be replaced with 'innodb_stats_transient_sample_pages=1' 1 issue/issues found
#
# Testing innodb_log_files_in_group
#
[mysqld]
innodb_log_files_in_group=4
innodb_log_file_size=2G
# Checking file
In MYSQLTEST_VARDIR/tmp/tmp1.cnf at line 2: Invalid option innodb_log_files_in_group 1 issue/issues found
# Updating file
Note: 'innodb_log_file_size=8G' added to [mariadbd] group based on innodb_log_file_size * innodb_log_files_in_group
Updated files:
MYSQLTEST_VARDIR/tmp/tmp1.cnf 2 issue/issues fixed
# Changed file
[mysqld]
innodb_log_file_size=2G
[mariadbd]
innodb_log_file_size=8G
[mysqld-5.7]
innodb_log_files_in_group=4
# Checking if file is ok now
No issues found
#
# Test not existing character set
#
[mysqld]
character_set_server=xxx
#
# Testing --add-XXX-replication-compatibility
#
[mysqld]
port=38
character-set-server=utf8mb4
# MySQL -> MariaDB compatibility
### File MYSQLTEST_VARDIR/tmp/tmp1.cnf:
[mysqld]
port=38
character-set-server=utf8mb4
[mysqld-5.7]
# The following options enable MySQL to replicate to MariaDB
loose-binlog_row_value_options=""
loose-binlog_transaction_compression=0
# Not required, but recommended for cross_replication
binlog_format=row
[mariadbd]
# The following options enable MariaDB to replicate to MySQL
encrypt_binlog=0
log_bin_compress=0
# Not required, but recommended for cross_replication
binlog_format=row
[client-server]
port=39
socket=/tmp/mysql.sock
#
# Testing copy-mysqld-groups
#
[mysqld-8.0]
socket="/tmp/mysql.sock"
# Testing with --copy-mysqld-groups=0
No issues found
# Testing with --copy-mysqld-groups=1 1 line/lines would be copied to [mariadbd] group 1 issue/issues found
Updated files:
MYSQLTEST_VARDIR/tmp/tmp1.cnf 1 issue/issues fixed
[mysqld-8.0]
socket="/tmp/mysql.sock"
[mariadbd]
socket="/tmp/mysql.sock"
#
# Testing path changing and different generated sections
#
[mysqld]
log-error = /var/log/mysql/mysqld.log
dummy=1;
default-storage-engine=innodb
socket=/var/lib/mysql/mysql.sock
datadir=/var/lib/mysql
#
# Test that second update of file with 'last' will no do anything
#
Updated files:
MYSQLTEST_VARDIR/tmp/tmp1.cnf 17 issue/issues fixed
No issues found
No issues found "Next command should not change anything"
No issues found
[mysqld]
default-storage-engine=innodb
Die Informationen auf dieser Webseite wurden
nach bestem Wissen sorgfältig zusammengestellt. Es wird jedoch weder Vollständigkeit, noch Richtigkeit,
noch Qualität der bereit gestellten Informationen zugesichert.
Bemerkung:
Die farbliche Syntaxdarstellung und die Messung sind noch experimentell.